CREATORS' CLOUD
    Remote Camera Tool

    Connecting the camera

    Connecting the camera

    Camera settings

    When using ILCE-1M2, ILCE-1 or ILCE-9M3

    When using the ILCE-9M2

    Camera connections

    Depending on your usage environment, connect the camera to the computer with a LAN cable using “Single connection” or “Multiple connection.”

    A USB-LAN conversion adaptor is required when using the application on an iPad. Connect the camera with a LAN cable to an iPad with a USB-LAN conversion adaptor connected.

    Note

    • When using the macOS or iPadOS version of the application, a message asking if you wish to allow connections to local networks may appear when you launch Remote Camera Tool. When this message appears, allow connections.
    • If the application is running on the iPad in the background, the link to the camera may be disconnected. In iPad [Settings], if you select [Multitasking & Gestures] and turn on [Stage Manager], you will be able to use multiple applications at the same time and the link to the camera will not be disconnected. Note that this setting is not available on all iPad models.

    Starting the application (Device List window)

    Starting Remote Camera Tool

    Double-click or tap the Remote Camera Tool icon to display the Device List window.

    Device List window. The [Refresh] button in the upper right of the window is highlighted.

    Device List window

    When you click or tap (Refresh), the cameras connected with a LAN cable to the computer or iPad are displayed.
    To connect a camera to Remote Camera Tool, you can either establish a connection using access authentication or perform pairing. For details, refer to “How to connect using access authentication” or “How to pair.”

    On a computer
    Double-click a connected camera to open Single Camera View, which allows you to perform various camera operations.
    Alternatively, click [Multi Camera View] to open Multi Camera View, which displays multiple cameras simultaneously and allows you to perform various camera operations.
    On an iPad
    Tap [Multi Camera View] at the bottom of the window to switch to Multi Camera View and then tap [Device List] to return to the Device List window.
    Device List window on a computer. Refer to the items below for details of marks A to P.
    • A. Map

      Allows you to switch to the Map display to visually check the camera positions. (Refer to "Map" below.)

    • B. Refresh

      Allows you to search among the connected cameras.

    • C. IP address dialog box

      Use this if the camera is not displayed by B (Refresh) or to connect by entering the IP address directly.

    • D. IP address of computer

    • E. [Connect] button

      To connect by entering the IP address directly, input the camera’s IP address in C, then click the [Connect].

    • F. [Ping] button

      Allows you to send a ping to the target camera. Input the camera’s IP address in C, then click the [Ping].

    • G. A list of connected camera(s) will appear.

      The cameras will be displayed in Multi Camera View in the order listed here.
      Click the item names to sort them in ascending or descending order.

    • H. Shutter release shortcuts

      You can assign shutter release shortcuts to the cameras you connected.

      * A total of up to 20 shutter release and AF operation shortcuts can be assigned to cameras.

    • I. AF operation shortcuts

      You can assign AF operation shortcuts to the cameras you connected.

      * A total of up to 20 shutter release and AF operation shortcuts can be assigned to cameras.

      After selecting [Tools] → [AF Operation Mode], you can switch AF operation modes.

    • J. Camera Name

      You can change the device names under the [Camera Name] column on this window.

      Note, however, that the name you changed on this window is effective only for Remote Camera Tool. The name of the camera displayed on the [Edit Device Name] menu will not change.

    • K. Camera status

      • Connected: The camera is connected.
      • Disconnected: The camera is disconnected.
      • Unidentified: Camera not found (for cameras that were previously connected)
    • L. Connect (toggle switches)

      By toggling ON/OFF, you can connect (Connected) or disconnect (Disconnected) each camera.

    • M. Pairing

      • Done: Pairing is complete. Double-click to connect.
      • Not yet: Pairing is incomplete. Double-click to open the pairing dialog box. (refer to “How to pair” below for further instructions)
      • - (dash): Displayed when a camera with the [Connect without Pairing] setting is set to [Enable], or when a camera with the “Access Authen.” setting is set to [On]. When connecting without pairing is enabled, you can double-click to connect.
    • N. Remove

      Allows you to remove the selected cameras from the list.

      • To remove all the cameras with the Status “Unidentified” from the list, select [Tools] → [Remove Unidentified Camera].
    • O. File transfer

      For details, refer to “File transfer.”

    • P. Multi Camera View

      Select the group you want to display in Multi Camera View and click or tap [Multi Camera View] to open Multi Camera View.
      Multi Camera View can display up to 20 cameras.

    Map

    Map display allows you to check the position of each camera by placing pins representing each camera on the set background image.

    You can drag and drop to move the pins on the map.

    Map display in the Device List window

    Using the Network Configuration File

    You can display in a device selection window only cameras with the IP addresses given in advance in a file by using Network Configuration File. This means you can eliminate the trouble of manually inputting IP addresses.

    From the menu bar, select [File] → [Network Configuration File Settings].
    On the iPad, tap (Menu) and select [Network Configuration List].
    Follow the prompts in the dialog box to specify the file containing items such as IP addresses.

    Listing example (setting values as listed after the “#” character)
    192.168.100.2,1,1 #IP=192.168.100.2, shortcut=1, Group=1

    You can also output a list of the cameras displayed in the device selection window to a Network Configuration File.
    From the menu bar, select [File] → [Export Network Configuration File].
    On the iPad, select from (Menu).
    Follow the prompts in the dialog box to specify items such as the delimiter character and output destination.

    For detailed usage instructions, refer to “Network Configuration File User's Manual.”

    NetworkConfigurationFile_Sample.csv
    Click to download a sample file.

    How to connect using access authentication (ILCE-1M2, ILCE-1 and ILCE-9M3 only)

    • The description below refers to “the computer,” but it applies to the iPad as well.

    On cameras that support the access authentication function, communication data can be encrypted over an SSH connection, allowing you to transfer data more securely.

    1. : When you configure camera settings, a message about access authentication appears on the camera. Select [Access Authen. Info].
      • If no message about access authentication is displayed, either perform the following setting on the camera or use pairing to connect.
      • MENU → (Network) → [Network Option] → [Access Authen. Settings] → [Access Authen.] → [On]
      • MENU → (Network) → [Network Option] → [Access Authen. Info]
      • To connect using pairing, refer to “How to pair.”
    2. PC : Launch Remote Camera Tool on the computer, and in the Device List window double-click the camera you wish to connect.
    3. PC : Referring to the access authentication information displayed on the camera, enter the user name and password on the computer and click [OK].
      • Once the input credentials have been saved, you will subsequently be able to connect without entering a user name and password.
      Access Authentication dialog box displayed on a computer.

      Note

      • When entering usernames, passwords, and fingerprints, make sure that no one is around to avoid the information on the screen being seen by others and to prevent unauthorized use.
      • If you unmask your password when entering it, there is a risk that it will be revealed to a third party. Make sure that no one is around before unmasking.
    4. PC : Confirm that the fingerprint displayed on the computer matches the one displayed on the camera, then click [OK].

    Deleting access authentication info

    You can delete access authentication info (user name and password) stored on the computer by selecting [File] → [Delete Stored Access Authen. Info] in the Device List window.

    On the iPad, select from (Menu).

    How to pair

    • The description below refers to “the computer,” but it applies to the iPad as well.

    To enhance security, pair the camera with the computer before use. Pairing is only required on the first connection.
    Pairing is not necessary if you connect using access authentication.

    1. PC : Double-click a camera with “Not yet” displayed under Pairing in the Device List window.

      The dialog box below will be displayed.

    2. : Configure the following setting on the camera to display the pairing standby screen.

      When using ILCE-1M2, ILCE-1 or ILCE-9M3: MENU → (Network) → [Cnct./Remote Sht.] → [Remote Shoot Function] → [Pairing]

      When using the ILCE-9M2: MENU → (Network) → [PC Remote Function] → [Pairing]

    3. PC : Select [Pairing].
      Pairing confirmation dialog box displayed on a computer. The [Pairing] button is highlighted.
    4. : On the camera’s pairing screen, select [OK].
    5. : Turn the power switch of the camera to OFF.

      Once you have turned the power switch to OFF, the pairing information will be saved on the camera. Wait for 10 seconds or longer before turning the switch to ON.

    Deleting the pairing information

    Pairing information is stored on both the computer (Remote Camera Tool) and on the camera. You can delete all pairing information from Remote Camera Tool by selecting [Tools] → [Delete All Pairing Information] in the Device List window.

    On the iPad, select from (Menu).

    • Pairing information cannot be deleted individually.
    • To delete the pairing information for the camera, perform the following settings to reset the network settings.

      When using ILCE-1M2, ILCE-1 or ILCE-9M3: MENU → (Network) → [Network Option] → [Reset Network Set.]

      When using the ILCE-9M2: MENU → (Network) → [Reset Network Set.]